Symptom
When renaming fields in the Language Adaptation, some fields for the Target Text are greyed out and cannot be edited, or some translations are missing from the text pool and/or inconsistent in the UI after an import via the Transport Management tool.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to the Administrator work center.
- Open the Language Adaptation link.
- Open the Adaptation XYZ you want to edit (XYZ stands for a Language Adaptation that you have created; the texts from the text pool have been collected before).
- Go to the UI Texts facet.
- Click Edit.
Result: Some fields in the Target Text column are greyed out.
Cause
The texts need to be collected another time.
Resolution
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Go to the Administrator work center.
-
Open the Language Adaptation link.
-
Open the language adaptation XYZ.
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Go to the Text Pool Selection facet.
- Click Collect Texts.
If, after several text collections, the Target Text field is still greyed out or read-only, there is a previously created language adaptation that already contains those fields and the texts cannot be overwritten (even if the field is blank). When you hover over the text, a tool tip displays the name of the original text pool. This only applies to the UI texts and messages since code and report texts do not have locks.
In case the original language adaptation was transported to the tenant at hand by means of the Transport Management tool, you can import the language adaptation once again. That will restore the missing translations in the language adaptation and the translations will be applied on the UI.
Keywords
language adaptation, target text, greyed, grayed , KBA , ap-rc-txa , language adaptation , target text , AP-RC-TXA , C4C Text Adaptation , Problem