Symptom
How to import Advances with Recovery Status INPROCESS?
Environment
Employee Central: Advances
Reproducing the Issue
When you import Advances with recovery status INPROCESS, the system throws error "???ADVANCES_INVALID_RECOVERY_STATUS???".
Cause
The error is caused by the validation for CREATE data operation. In normal UI operation (manual - not import) the status always remains as NOT STARTED, but this validation is triggered only during import scenario. So in such cases, we do not want to cause inconsistencies in system if RECOVERY STATUS is apart from NOT STARTED (because in this case already deductions is in process which is a valid use-case).
Resolution
We can import the following.
- First only Non-Recurring Payment (NRP) records (without installments and deductions) and modify the RECOVERY STATUS to NOT STARTED.
- After the successful import, we can import the Installment records and the NRP records with RECOVERY STATUS as IN PROCESS.
See sample attachment files. Import the nostartVersion.zip file first and after success, upload the inprogressVersion1.zip file.
See Also
Keywords
ADVANCES_INVALID_RECOVERY_STATUS, ECT-84812, NOT STARTED, , KBA , LOD-SF-EC-ADV , Advances , How To
Product
Attachments
nostartVersion.zip |
inprogressVersion1.zip |