Symptom
- When attempting to take a course from the Bizx home page on the learning tile, the user receives an error:
Please report the following error to your system administrator:
Ticket <some random number> -
Additionally access to Learning dropdown provides the same issue.
-
Only the user experiences the issue as BizX proxy produces a different error: The request operation is not available.
Environment
- SAP SuccessFactors Learning Management System (LMS)
- SAP SuccessFactors Platform (BizX)
Reproducing the Issue
-
Ensure SSO is utilized in BizX integrated environment with LMS
-
Click on any learning item available on the BizX homepage learning tile
-OR-
Click on the Learning dropdown from BizX
Cause
-
After researching application log of specified ticket number, it was found:
http-nio-8080-exec-11 - <instance> - https://<instance>.plateau.com/learning/saml/login?login=true&relayState=User&idp=%2fsf%2fidp%2fSAML2%2fcompany%2f<companyID> - errorpage_jsp - Ticket=336025 from errorpage.jsp. StackTrace is Given URL is not well formed
java.lang.IllegalArgumentException: Given URL is not well formed
...
Caused by: java.net.MalformedURLException: no protocol: /sf/idp/SAML2/SSO/Redirect/company/<companyID>
Resolution
-
Clearing the affected user's browser cache resolves the issue.
-
Additionally using a browser with private or mode where cache is not stored may also need to be perfomed after clearing the cache.
Keywords
SF LMS BizX LM course items class homepage todo to-do plan attempt attempts click try , KBA , LOD-SF-LMS-SSO , LMS SSO , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-LMS-INT , Integrations with BizX , Problem