Symptom
When opening Contacts (unlike Accounts) the link to a Registered Product does not show in their own Products facet when the Contact person is not added as a Contact.
Environment
SAP HYBRIS CLOUD FOR CUSTOMER
Reproducing the Issue
- Go to the Products work center.
- Go to the Registered Products view.
- Open Product ABC (ABC represents the relevant Registered Product).
- Check the Involved Parties.
- You see Contact DEF (DEF represents the contact name)
- Open the Customer, navigate towards the Products facet.
- You can see ABC is maintained on the account.
- Open the Contact DEF.
- Navigate to the Registered Product facet.
Result : the Registered Product ABC cannot be found on the Registered Product facet for the Contact DEF.
Cause
If the involved party is a Contact Person added as a Contact, the Contact screen will only show those registered products.
Registered Products where the Contact is added as any other party won't be show in the Contact screen.
Resolution
This is the expected behavior.
Keywords
Registered Products, Contacts , KBA , LOD-LE-IBA-IPO , Installation Point , Problem