SAP Knowledge Base Article - Public

2568213 - Involved Contacts, When Accessed From Registered Product, Do Not Show the Related Products, if they do Not Have the Role Contact in Involved Party

Symptom

When opening Contacts (unlike Accounts) the link to a Registered Product does not show in their own Products facet when the Contact person is not added as a Contact.

Environment

SAP HYBRIS CLOUD FOR CUSTOMER

Reproducing the Issue

  1. Go to the Products work center.
  2. Go to the Registered Products view.
  3. Open Product ABC (ABC represents the relevant Registered Product).
  4. Check the Involved Parties.
  5. You see Contact DEF (DEF represents the contact name)
  6. Open the Customer, navigate towards the Products facet. 
  7. You can see ABC is maintained on the account.
  8. Open the Contact DEF. 
  9. Navigate to the Registered Product facet.

Result : the Registered Product ABC cannot be found on the Registered Product facet for the Contact DEF.

Cause

If the involved party is a Contact Person added as a Contact, the Contact screen will only show those registered products.

Registered Products where the Contact is added as any other party won't be show in the Contact screen.

Resolution

This is the expected behavior.

Keywords

Registered Products, Contacts , KBA , LOD-LE-IBA-IPO , Installation Point , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions