Symptom
For some of your Activities (for example Tasks, Appointments, etc.) the value for the field Category is showing up as code.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
This issue can happen in several areas. In our example we use Appointments.
-
Go to the Activities work center.
- Go to the Appointments view.
- For some Appointments you notice that the Category value is showing as code, not as description both when opening the object and when using the mouse-over.
Cause
You have restricted the Category values with Code List restriction and the value used in the object is not allowed for your user.
Resolution
Allow the value within your Code List Restrictions.
-
Go to the Administration work center.
- On the General Settings page click the Code List Restrictions link.
- Select your relevant restriction (search for Code to Restrict = Category).
- Add the relevant value(s).
See Also
The full list of values are shown in your Business Configuration.
-
Go to the Business Configuration work centre.
- Select the relevant Implementation Project.
- Open the Activities List.
- Go to the Fine Tuning Activity for Activities.
- Click the Maintain Categories link.
Here you have the full list of Categories as well as the option to create new ones.
For detailed information on how to do this, please refer to the Administrator Guide (Administrator Guide > Integration > Integrate your Data using Code Lists > Define Code List Restrictions).
Administrator Guide is available under: https://help.sap.com/viewer/cea15f900ca04c4faa35d3044577fe27/1708/en-US/ (please note that this link may change)
Keywords
Category, Code, ID, Code List Restriction, Activities, Appointments, Tasks, Phone Calls, wrong, showing , KBA , LOD-CRM-ACT , Activities , Problem