Symptom
When I click on the Company(Legal Entity) field in job info, an application error occurs with the following fingerprint id: fingerprint=9d56e2deb0cc09014a23b7a299befbfc5c7b2ab0
Environment
Employee Central - Job Information
Reproducing the Issue
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Search for a user
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On personel Profile select "Take Action" and "Change Job and Compensation Info"
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Select both Job and Compensation info
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Select Company
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Edit what needs to be edited and click save
- Also occurs in new hire wizard
Cause
On the legal entities in manage data, the country field is left blank, despite the fact that it is a required as of the 1708 release on the legal entity
Resolution
You must add a country to each of the legal entities. This is required and must be done
In Employee Central, there is a hierarchy amongst a number of the standard objects
Country is the top of the hierarchy, followed by Legal Entity, so it is vitally important that a country is chosen for each legal entity
The quickest way to fix the legal entities, if several them need to be fixed, is to do the following
1. Import and Export Data
2 Export Country Objects > Don't include Dependencies and select all data records
3. Enter a country for each legal entity // FYI, must be the three-letter country code, not the label of the country
4. Re-Import the file
Alternatively, the legal entities can be fixed manually in manage data
1. Go to Manage Data
2. Search for Legal Entities (Maybe Different in each Instance depending on the name of the object in Configure Object Definitions
3. Add a country to each legal entity and save the changes after updating each legal entity, one by one
Keywords
fingerprint=9d56e2deb0cc09014a23b7a299befbfc5c7b2ab0, Job Information, Country, Legal Entity, Company, Company Code, Company Field, Legal Entity, Company Dropdown, Legal Entity Dropdown, MDF, Application Error, Job Info , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-EC-MDF , MDF & EC2MDF Migration , Problem