SAP Knowledge Base Article - Public

2568542 - Account not Found for Company and Customer/Supplier While Assigning an Employee to a Payment

Symptom

You create an outgoing check or cash payment for an employee. Or you try to allocate a payment to an employee through a payment allocation. An error message appears 'Account not found for company XYZ (XYZ stands for the company ID) and customer/supplier ABC (ABC stands for the customer or supplier ID' when trying to assign the employee to the payment.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Payment Management work center.
  2. Go to the Common Tasks and select New Outgoing Check.
  3. Enter the Company and Payee fields.
  4. Select a Payment Amount, Currency and Bank Account ID.
  5. Press Assign on Account Payment button. 
  6. Select Customer/Supplier ID and press OK. Alternatively, assign the employee in the Customer/Supplier ID field of the payment allocation. 

The error message 'Account not found for company XYZ and customer/supplier ABC' appears.

Cause

For the employee ABC no employee account exists as no expense report or expense was ever created associated with the employee. 
The system logic here is that payments can only be created for employees if open expense reports/expenses exist for them. Advance payments without any open items are currently not supported in SAP Business ByDesign.
For a payment creation an employee account must exist associated with account determination group 4050 - Employees.

Steps to check if an employee has Account Determination group 4050 assigned:

  1. Go to the Payables work center.
  2. Go to the Supplier Accounts view.
  3. Show All Employees.
  4. Search for the employee you are creating the payment for.

    Note:
    No results can be found.

Resolution

To overcome this situation you could create an expense report for a very minor value such as 0,01 LC (Local Currency), but not 0,00 LC(Local Currency).

This way, an employee account is associated with account determination group 4050 - Employees and you can find the Employee Account Monitor in Payables workcenter --> Supplier Accounts view--> Filter with All Employees.

After that, you can cancel the expense report again.

Another workaround would be to migrate the account determination group 4050 for the employee. See below under See Also.

See Also

2044246 - Employees Missing in Supplier Accounts View of Payables Work Center

Keywords

payment, employee, account not found; Konto für Unternehmen und Kunde/Lieferant nicht gefunden , KBA , SRD-FIN-ACP , Payables , SRD-FIN-ERM , Travel and Expense Management , Problem

Product

SAP Business ByDesign all versions