Symptom
The Admin Guide "Implementing and Configuring Workflows in Employee Central" describes in page 26 (7.2 Triggering Workflows Using Business Rules) how to set up business rules that trigger workflows. However, I am stuck with step 4, where the Admin guide talks about the THEN statement: There is NO wfConfig field available.
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Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
Follow the steps as indicated in the handbook "Implementing and Configuring Workflows in Employee Central" at 7.2.1 Defining Workflow Derivation Rules with Business Rules
- Navigate to the Admin Center. In the Tools search field, type Configure Business Rules.
- On the Business Rules UI, select Basic rule and then choose a base object. You do not need to specify a Rule Type.
- Configure the IF condition based on your business case.
- In the THEN statement, set the wfConfig field with an appropriate workflow configuration
Here the user cannot find wfConfig field in rule menu
Cause
It is a configuration issue, because the Business Rules for Workflow Derivation is not Enabled.
Resolution
Enable setting - 'Enable Business Rules for Workflow Derivation'
Thereafter, you should be able to find the wfConfig in the rule menu after selecting the application-specific scenario "Trigger Workflows", under Employee Central Core.
Remember:
As a customer, you do not have access to provisioning. To complete tasks in provisioning, you can get in touch with support, partner / professional services.
See Also
Keywords
wfConfig not availale in the rule, wfConfig, Workflow, Business Rule, unable to find wfConfig, wfConfig, trigger workflows, workflow rule , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , Problem