SAP Knowledge Base Article - Public

2569670 - How to Add a KUT Field to a Custom Tab

Symptom

You want to create a new field and add it to a custom tab on the Account TI.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Open any Account ID.
  4. Select Adapt--->Edit Master Layout.
  5. Open the tab DEF (DEF represents the name of the tab).
  6. Hover over an already existing field.
  7. Select the Add Items button.
  8. Select Add Fields.
  9. There is no New Field button.

Cause

A new field can first be added to the header and then dragged onto the custom tab.

Resolution

  1. Go to the Customers work center.
  2. Open the Accounts view.
  3. Open any Account ID.
  4. Select Adapt--->Edit Master Layout.
  5. Hover over a field in the Account header area and select the Add items icon.
  6. Select Add Fields.
  7. Select the New Field button.
  8. Fill in all necessary values and select Save and Close.
  9. Then select this new field and choose Apply.
  10. Open the tab DEF.
  11. Now drag and drop the field onto the tab.
  12. Select Adapt--->End Layout Changes.
  13. It should now be possible to view and edit the new field on the custom tab.

Keywords

Account, custom tab, Customers,  New Field, Edit Master Layout, button , KBA , account , custom tab , customers , new field , edit master layout , button , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions