SAP Knowledge Base Article - Public

2569896 - Intelligent Services Center - event New Hire is not raised - Employee Central

Symptom

Though there have been New Hires in the instance recently, no New Hire event was raised in Intelligent Services Center (ISC).

Environment

  • SAP SuccessFactors Employee Central
  • Intelligent Services Center (ISC)

Cause

Business rules are not configured correctly in the system.

Resolution

There are pre-delivered business rules for the events. These rules can be imported from Admin Center -> Import and Export Data -> Import Data -> SuccessStore.

For New Hire, the rule is EVENT_NEWHIRE (SAP_EVENT_NEWHIRE). This rule should be added to Job Information (jobInfo) in Admin Center -> Manage Business Configuration as an onPostSave rule with base object as Job Information Model. After this is done, all new hire events will appear in Intelligent Service Center.

This is explained in the handbook Managing Employment in Employee Central - Intelligent Services under the section "Configuring Intelligent Services Rules", sub-section "How to Configure Prepackaged Employee Central Rules".

Keywords

ISC, event center, intelligent service center, new hire event not triggered, new hire event, new hire, , KBA , LOD-SF-EC-ITS , Intelligent Services (EC Components Only) , Problem

Product

SAP SuccessFactors Employee Central all versions