SAP Knowledge Base Article - Public

2570374 - How to Make Contacts Facet Visible in Leads

Symptom

You are trying to enable the Contacts facet for leads but you are not able to make it visible by changing the Master layout or a Page Layout even though it can be added and is set to visible.
After setting the Contacts facet to visible and saving the layout changes it is still not visible.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

Cloud for Customer

Reproducing the Issue

  1. Open the Sales work center.
  2. Select the Leads view.
  3. Open a lead from the list.
  4. Enter Adaptation Mode.
  5. Select 'Tabs'
  6. Find 'Contacts' and set it to 'Visible'

Cause

The contact object related to the lead has not yet been created - the lead has not yet been converted and the contact currently associated to the lead does not yet exist in the system - it is still 'in preparation'.

Only if the tab is set to visible AND the relevant contact associated to the lead has a master data entry (after lead conversion or association, or if existing master data (existing account/ contact were used), will the facet appear as visible on the lead.

Resolution

The facet Contacts is only available for leads that have Active/Existing accounts. Once the lead is converted into an opportunity or it is converted into/associated with an account/contact will the Contacts facet appear. Alternatively, it will also appear if you create a lead with an existing account and contact.

Keywords

"Contacts" "Lead" "not visible", contacts, visible , KBA , c4c , contacts , facet , not visible , leads , LOD-CRM-MKT-PRO , Prospect , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions