Symptom
Primary contact is not fetched for custom party role.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
You have already created a custom party role and activated as involved party for the desired business object.
We will use business object Ticket as example.
- Go to the Service work centre.
- Select the Tickets view.
- Search and open a random ticket.
- Select the Involved Parties facet.
- Click the Add button.
- Select Role ABC (ABC represents the name of the custom party role).
- Select the respective business partner for field Party.
- Click the Add button.
You expect the primary contact associated with the chosen business partner to be displayed in the Contact column row of the Involved Partiedstable.
Cause
This functionality is currently not supported.
Resolution
This is a new system requirement.
Keywords
Involved Parties, Custom Party,Primary Contact. , KBA , involved parties , primary contact , custom party , LOD-LE-RC-PAP , Party Processing , LOD-CRM-SRP , Service Request Processing , Problem