SAP Knowledge Base Article - Public

2570411 - Calibration Session Using Employee Profile as the Data Source

Symptom

When launching a Calibration session that uses the Employee Profile as the data source, unexpected or incorrect ratings are being pulled into the Calibration session.

Environment

SAP SuccessFactors Performance Management Calibration

Reproducing the Issue

  1.  Create ratings in Employee Profile for the subjects of a Calibration session.
  2.  Create a Performance Management forms for the above subjects.
  3.  Launch a Calibration session for these subjects.
  4.  Upon examining the ratings in the Calibration Session, you may find that some or all users have ratings pulled into the session that do not match the Employee Profile entries that were expected.

Cause

Explanation of when to use Employee Profile as the data source of a Calibration Session:

  • The Calibration module allows the use of Performance Management forms and Employee profile entries as a source for Calibration data.
  • The use of Employee Profile data is intended for scenarios where there is no Performance Management form data available, for example in new implementations.
  • In that case the performance ratings from the previous solution could be uploaded into the Employee Profile to allow Calibration sessions to be run.

When selecting the Employee Profile as the source for Calibration data the following criteria are applied by the application:

  • Ratings that fall inside the date range set for the Calibration Session will be used.
  • Ratings whose validity period falls closer to the end of the Calibration date range will be preferred.
  • The ratings considered are not necessarily displayed on the Performance portlet in the Employee Profile.
  • Depending on its configuration there can be multiple ratings stored in the system that are not visible at first glance.
  • These include but are not limited to incomplete Performance Management forms or older Performance data uploads

Unexpected Ratings:

  • The main cause for unexpected ratings in Calibration sessions is the presence of live Performance Management forms in the instance or ratings comming from other active calibration sessions including the same subject
  • As these will often be the most recent rating as well as fitting the Calibration date range these will often be preferred by the application

Resolution

If Employee Profile is being used as Data Source in your calibration and you notice any unexpected rating which is possibly due to an existing Performance form, we now have the option to exclude other rating sources from the Employee Profile Data. This can be set via Admin Center > Manage Calibration Settings > Exclude Rating Sources from Employee Profile Data.

For more information, please refer to this article 2723567 - Configure which ratings to be picked up in Calibration Session

Note:

When a Calibration Session is activated it will pull the rating from the Profile.
If this rating is later edited (for Profile ratings directly on the profile or for PM forms, by sending the form back to in process and then completing it again), the calibration session will not update the rating it has already pulled.

Deactivating and re-activating the Calibration Session will not update the rating in the session.

Keywords

Calibration session, Employee Profile, performance history, data source, date range, source, data, PM, EP, incorrect ratings , KBA , LOD-SF-CAL-EP , Calibrating with Employee Profile , Problem

Product

SAP SuccessFactors Performance & Goals all versions