Symptom
When accessing People Profile an application error occurs, and the Competency portlet does not load.
Environment
- SAP SuccessFactors Career Development Plan
- SAP SuccessFactors People Profile
Cause
This error may occur due to a missing configuration in the back-end, for instances with SuccessFactors Learning (LMS) integrated.
Resolution
The Competency Portlet shows LMS Learning Activities link, if LMS is integrated in the system. The feature "Transcript" is part of the LMS integration and a required setting, when using the LMS link.
To correct this error, it is necessary to enabled the feature "Transcript" on Provisioning. To complete this request, you can contact your Implementation Partner or Cloud Product Support, through an case, as access to the back-end of your instance is required.
See Also
In case you are having this issue when assigning Learning Activities on Succession Org Chart, you can refer to the KBA 2547449 - Application error on Assign Learning in Succession Org Chart.
If the scenario described in this article does not match your, you can find a solution in the the KBA 2213289 - Application Error in the Employee Profile / Scorecard / People Profile.
Keywords
competencies portlet learning management system URL error message "AccessDeniedException" "activity=Activity{type=SERVICE, name='com.successfactors.cdp.service.transcript.FindTranscriptInCatalog', context=null" , KBA , LOD-SF-CDP , Career Development Planning , LOD-SF-CDP-POD , Home Page, Pods and Portlets, To Do List , LOD-SF-CDP-SYS , System Performance , LOD-SF-EP-PP3 , DO NOT USE [Use a sub component of LOD-SF-EP] , Problem