SAP Knowledge Base Article - Public

2570501 - Country field is not visible in Workflow Information page for any Job Information changes made

Symptom

A field 'Country' is not included in the 'Workflow Details' of a Workflow triggered by a change to a user's Job Information, despite no change being made to the field when changing the Job Information.

Environment

SAP SuccessFactors Employee Central - Workflow

SAP SuccessFactors Employee Central - Job Information

Reproducing the Issue

  1. Navigate to Emplyoee Profile.
  2. From Take Action > Change Job and Compensation Information.
  3. Select Job information and make some changes.
  4. Click on Submit and workflow is triggered.
  5. Proxy as approver and check the approval details page.
  6. We do not see Country field anymore.

Cause

  1. When Centralized Services were introduced in Workflow, the calculation of changed fields which are displayed on the Workflow Details page has changed compared to the legacy code.
  2. As the country-of-company is a transient field, it is not displayed on the Workflow Details page.

Resolution

This is Expected System Behavior, since Centralized Services have been introduced in the Workflow Logic.

Keywords

Employee Central, Job Information Portlet, Country field, Job Information Workflow, Workflow Details, Country, countryOfRegistration, Job Information, Country of Company, INC9168284 , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-JOB , Job Information , Problem

Product

SAP SuccessFactors Employee Central all versions