Symptom
When an activity task is created, the task owner receives a notification: “Task '<Task Subject/Name>' assigned to you is past due date”, even though the task’s due date is set in the future.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to the Activities work center.
- Go to the Tasks view.
- Click New to create a new task (e.g., Task ABC).
- Enter all mandatory details and click Save.
- The task owner receives a notification: “Task 'ABC' assigned to you is past due date”, even though the due date is set correctly in the future.
Cause
In Business Configuration > Fine-tune Activities, for the activity “Business Task Management for Overdue Task Activity for Owner”, the Activation Date under Task Type Details is maintained as 0. This configuration causes the system to trigger the notification immediately when the task is created, regardless of the actual due date.
Resolution
To ensure that the notification is triggered after the task’s due date, maintain the Activation Date and Expiry Date in the activity:
Business Configuration > Fine-tune Activities > Business Task Management for Overdue Task Activity for Owner
Notifications will be triggered based on the dates maintained in this activity.
Keywords
Notification, Task, Past Due Date, Owner, Activities , KBA , LOD-CRM-ACT , Activities , Problem
SAP Knowledge Base Article - Public