SAP Knowledge Base Article - Public

2570932 - Error: Same IBAN is Maintained for Different Bank Accounts

Symptom

When updating a supplier's bank details, an error message stating "The same IBAN is maintained for different bank accounts" appears, despite setting the old bank details to an old date.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Payables Work Center.
  2. Navigate to the Supplier View.
  3. Select the supplier and click on Edit.
  4. Go to the Financial Data tab and choose the Bank Data sub-tab.
  5. Add two different bank accounts with the same IBAN, ensuring the first bank account is delimited.
  6. When trying to add a new row, you receive the error message: "The same IBAN is maintained for different bank accounts."

Cause

Currently, there is a constraint that makes it impossible to maintain the same IBAN for different bank instances.

(Note: "Instance" here refers to two records for the bank directory entry, which you maintain under Liquidity Management > Master Data > Bank Directory.)

Resolution

To remove/delete the bank entry from the supplier, create a new line. For audit reasons, this change will be visible in the change history, thereby sufficing audit requirements. 

Additionally, consider using the same instance of the bank directory entry by updating it with the new details (such as the name, etc.)

Keywords

IBAN, Bank Accounts, , KBA , iban , bank accounts , AP-BP-BP , BusinessByDesign: Business Partner , How To

Product

SAP Business ByDesign all versions