Symptom
Confirm Delivery button is Disabled for Shopping Cart
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to Home work center.
- Select view My Requests under Self Services.
- Filter with Shopping Carts - Open for Confirmation.
- Confirm Delivery and Quick Confirm Delivery buttons are disabled.
Cause
- The quantity in the shopping cart should match the quantity in the purchase order. The shopping cart quantity is not the correct quantity to be delivered, as the PO quantity is the correct quantity to be delivered.
- Goods and Services Receipt Expected should be checked in the Basic Data of the Purchase Order that was created as a follow-up to the Shopping Cart.
- The Confirm Delivery button will be enabled only for requester or creator of Shopping Cart.
- The Quick Confirm Delivery button will be disabled in case of limit items.
- The question related to confirming delivery has not been scoped.
Resolution
Steps to enable the scoping question to activate the button
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Select Edit Project Scope button.
- Navigate to step 4 Questions.
- Drill down Purchasing > Self-Service Procurement > Shopping Carts.
- Under Decentralized Goods and Services Receipts the question "Do you want to allow your employees to confirm the receipt of goods or the completion of services?" is not in scope and hence disabled.
Once the flag is set, the functionality will be enabled.
See Also
Keywords
Confirm Delivery, Shopping Cart, Confirm Delivery Disabled, Quick Confirm Delivery Greyed/Disabled , KBA , AP-REQ-IR , Internal Request , Problem
Product
SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1711 ; SAP Business ByDesign 1802 ; SAP Business ByDesign 2308 ; SAP Business ByDesign 2311 ; SAP Business ByDesign 2402 ; SAP Business ByDesign 2405