Symptom
Values for the Longitude and Latitude fields was entered, however the system is not accepting these values.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to the Customers work centre.
- Go to the Accounts view.
- Change filter to show All.
- Open: ABC (Where ABC stands for a Customer Account).
- Facet: Addresses.
- Pane: Details.
- Fields: Latitude and Longitude.
- Use a GPS Locating service, and for example choose SAP Galway.
- It will give you the following values: 53.30163340000001 and -8.987642499999993.
- Even though these are correct co-ordinates it will tell you these values are not valid.
--> If these fields cannot be seen, please enable via Adaptation Mode.
Cause
The system does not accept this Longitude and Latitude format, as it will only accept a comma ' , ' not decimal points ' . '
Resolution
The system will only accept 17 digits before the comma, and only 14 decimal places are permitted in total.
An accepted format is:
- Latitiude: 11,111111
- Longitiude: -1,1111111
(It is not needed the numbers that come after these - it is possible to double check this in the GPS locator if used. It does not change the location.)
Keywords
Error, unable to, doesn't work, Longitude, Latitude , KBA , LOD-CRM-ACC , Account , LOD-CRM-OPP , Opportunity Management , LOD-CRM-ACT , Activities , LOD-CRM-ACT-VST , Visit Planning , Problem