Symptom
You have a requirement where if an Account/Individual Customer have more than one e-mail address maintained than the workflow rule should send e-mail to only to main e-mail id.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to Administrator work center.
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Go to Workflow Rules view.
- Open the workflow rule XYZ1 (Where XYZ1 is workflow of type E-Mail )
- In the overview , you see that the recipient determination is maintained as Customer / Account/ Individual Customer
Once the workflow is triggered, you see that all the E-Mail address maintained for the business partner are receiveing an E-Mail.
Cause
This is the expected system behavior and while triggering E-Mail for workflow , system reads all the addresses for the associated business partner from the address overview , irrespective of the main indicator.
Resolution
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Workflow rules, E-Mails, Workflow, Business Partners, Address, Customer , KBA , e-mail , workflow rules , LOD-CRM-WKF , Workflow , Problem