Symptom
You are creating an Account/Opportunity from a Lead and the Account Owner appears blank; you expected to see the Account/Opportunity Owner as the Lead Owner.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales work center.
-
Select the Leads view.
- Open Lead ABC (where ABC stands as ID of the Lead).
- Click in Actions button.
- Select Convert to Opportunity/Account.
You expect to see the Opportunity/Account Owner field filled with Owner from Lead.
Cause
The system does not considers that the Lead Owner will be the the Account/Opportunity Owner.
Resolution
This is the system standard behavior. You can, as workaround, create a workflow rule to achieve the desired behavior. For this, please follow the steps below:
- Go to the Admnistration work center.
- Select the Workflow Rules view.
- Click in the New button.
- Fill in a description.
- Select Business Object dropdown menu as 'Account'.
- Select Timing dropdown menu as 'On every Save'.
- Click in Next button.
- Click in Add Group button and fill in information as below:
- Click in OK button.
- On the line of the created condition, click in the green '+' button named Add Condition. Fill the information as below:
- Click in OK button.
- Click in the Next button.
- In the Rule Type dropdown menu, select 'Action'.
- In the Select Action dropdown menu, select 'Assign Me as Owner'.
- Click in the Next button.
- Click in Activate Button.
- Click in the Finish button.
Keywords
Account, Lead, Opportunity, Owner , KBA , LOD-CRM-ACC , Account , LOD-CRM-LM , Lead Management , How To