Symptom
-
Password for an API user is changed and so the processes start failing.
-
Hence the new password was updated in Boomi-> Atom Management-> Environment Extensions.
-
But even after the change the process is failing with errors like: 'Invalid username/password', 'Unable to authenticate'.
Environment
Boomi
Cause
The reason for the error is that the password was changed but this change is not reflecting under the 'Audit Logs' option and hence not reflecting in the subsequent executions.
Resolution
After changing the password, once verify that the change is reflected under 'Audit Logs' and if not, kindly follow below steps in order to resolve the issue.
1. Click on the 'Use Default' checkbox next to the Password field and click on Ok.
2. Now again open the same connector and uncheck the 'Use Default' checkbox and enter the correct password by clicking on Encrypted.
NOTE: If you verify the Audit Logs after this, you will see two new entries for the changes made in Step 1&2 and this ensures the password change will now reflect in the subsequent executions.
See Also
Bug already submitted to DELL and tracked under https://community.boomi.com/ideas/3617
Keywords
Password change, Invalid username/password error, Boomi connector, Environment extensions, 401 Unauthorized, Boomi, Incorrect Password, Authentication error , KBA , LOD-SF-INT-BPI , Dell & Boomi Infrastructure , LOD-SF-INT , Integrations , Problem