Symptom
Below Error while accessing manage business configuration
Environment
SuccessFactors employee central business configuration
Reproducing the Issue
Navigate to Admin center--->Search manage business configuration
Cause
Issue can be due to different reasons.This kba explains the issue caused by wrong display format in succession data model
Resolution
Access to provisioning is required to fix this issue.Reach out to your partner or create a support ticket.
Exact reason can be identified from the logs
How to check Logs
Login to provisioning----->Navigate to monitor jobs----->Filter job type by "Synchronize Business Configuration"--->Click Details
See the line after the "null object returned from".Here the keyword is EPDisplayPatterConfig.getLocale().
How to resolve
Above logs clearly explains that the issue is due to display format configuration
Step 1:Download succession data model. Remove below 2 sections from the data model
Step 2:Upload the updated succession data model
Step 3: Navigate to Monitor jobs and check the status of the job.It will be successful
Step 4:Login to the system--->Admin center---->Manage business configuration---->Create the removed display pattern from Business configuration UI.
Field display format will be displayed under Employee profile section.Click Create new--->Enter details and save.
Keywords
Business Configuration BCUI Business Configuration is locked EPDisplayPatternConfig Synchronize business configuration , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem