Symptom
You are trying to generate a PDF Preview for a Service Request, but you receive a message No Records Found. Also no Output History is generated and when you go to Edit Output Settings you receive the same message.
Environment
Silverlight and HTML5 Client.
Reproducing the Issue
- Go to Service Desk Work Center
- Open Service Request View
- Search for Service Request ABC (ABC is a Service Request ID)
- Select this Service Request
- Click on Preview
- You will receive the message No Records Found
Cause
The form template selection is based on the country which is maintained in the Sales Unit. If not, we use the seller country.
Resolution
You can check if party determination rules are maintained in your system, where Sales Unit is fetched corresponding to the Account for which the Service Request is created.
Alternatively, you can create a New template with 'No Country' version and language as EN, for example, so that this template always gets picket in such a scenario.
Steps to be performed for this proposal is:
- Go to Application and User Management Work Center
- Go to Form Template Maintenance
- Currently there exist template with name Service Request, for this example with properties Country as United States AND Language as English
- Select this Form
- Click on Copy
- Create a New Variant with No Country version and the language as English.
Keywords
Output Settings, Preview, No Records Found, Service Request Template, Service Request Form , KBA , AP-RC-OUT , Output Management , Problem