SAP Knowledge Base Article - Public

2573146 - Not Possible To Delete E-Mail Channels

Symptom

You cannot delete existing E-Mail Channels.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

You have created an E-Mail Channel which you no longer intend to use.

  1. Go to the Administration workcenter.
  2. Go to the Service and Social view.
  3. Under Communication Channels, select E-Mail Addresses.

Result: there is no option to delete any of the maintained channels.

Cause

This is expected system behaviour.

Resolution

There is currently no option to delete e-mail channels due to the reason that deleting a channel could lead to inconsistencies of data as there could be cases that tickets have been already created for this channel.

In case you need to remove the email channel from when sending a reply from within tickets, you can then mark the channel as Inbound only. This will remove the channel from the reply option.

  1. Go to the Administration workcenter.
  2. Go to the Service and Social view.
  3. Under Communication Channels, select E-Mail Addresses.
  4. Mark the checkbox Inbound Only.

In some cases you may want to stop using an old email channel, but you still want to use the email adress from that channel. In this case please do the following:

  1. Go to the Administration workcenter.
  2. Go to the Service and Social view.
  3. Under Communication Channels, select the E-Mail Address that you do not want to use anymore.
  4. Edit the email adress to a invalid email e.g DO_NOT_USE_export@xxxx.com or INVALID_CHANNEL_export@xxxx.com. (The xxxx represents  a random domain being used)

Keywords

Email, channel, Administration, email channel, delete , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions