Symptom
You cannot delete existing E-Mail Channels.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
You have created an E-Mail Channel which you no longer intend to use.
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Go to the Administration workcenter.
- Go to the Service and Social view.
- Under Communication Channels, select E-Mail Addresses.
Result: there is no option to delete any of the maintained channels.
Cause
This is expected system behaviour.
Resolution
There is currently no option to delete e-mail channels due to the reason that deleting a channel could lead to inconsistencies of data as there could be cases that tickets have been already created for this channel.
In case you need to remove the email channel from when sending a reply from within tickets, you can then mark the channel as Inbound only. This will remove the channel from the reply option.
-
Go to the Administration workcenter.
- Go to the Service and Social view.
- Under Communication Channels, select E-Mail Addresses.
- Mark the checkbox Inbound Only.
In some cases you may want to stop using an old email channel, but you still want to use the email adress from that channel. In this case please do the following:
-
Go to the Administration workcenter.
- Go to the Service and Social view.
- Under Communication Channels, select the E-Mail Address that you do not want to use anymore.
- Edit the email adress to a invalid email e.g DO_NOT_USE_export@xxxx.com or INVALID_CHANNEL_export@xxxx.com. (The xxxx represents a random domain being used)
Keywords
Email, channel, Administration, email channel, delete , KBA , LOD-CRM-SRP , Service Request Processing , Problem