Symptom
User faces the following error when opening an Opportuntiy - 'Please Enter a Reference Document Item Type'.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to Sales work center.
- Choose the work center view Opportunity.
- Find XYZ (XYZ represents opportunity ID).
- Open the opportunity and notice that the error 'Please Enter a Reference Document Item Type' is displayed.
Cause
Scoping Question not checked in Business Configuration.
Resolution
-
Go to Business configuration work center.
- Choose the Project.
- Edit the project scope.
- Go to scoping step.
- Choose sales view.
- Choose sub view Product and Service Portfolio for Sales.
- Choose Sell Standard Products and select the check box.
- Choose next and finish the scoping.
Please note that the error message will continue for already affected Opportunities because the added product has missing data. If you must re-use existing opportunities, those can be fixed by below steps:
- Perform the scoping change, which is a pre-requisite for any solution.
- Delete existing products from the existing opportunities.
- Re-add the products to the opportunities.
This can be done in mass fashion using Data Workbench with the Opportunity Product object.
Keywords
Cloud For Customer, Opportunity, Please Enter a Reference Document Item Type, Scoping, Error, Sales , KBA , LOD-CRM-OPP , Opportunity Management , Problem