SAP Knowledge Base Article - Public

2574242 - Intelligent Services - Termination event not logged - Employee Central

Symptom

An user was terminated in the instance, but the event did not log in the Intelligent Service Center (ISC) -> All Events.

Environment

Employee Central: Intelligent Service Center

Reproducing the Issue

  1. Enable Intelligent Service Center.
  2. Configure RBPs for it.
  3. Add the related pre-delivered business rules as onSave to Job Information portlet. The pre-deleivered rule for Termination event is EVENT_TERM (SAP_EVENT_TERM).
  4. Terminate an employee through Take Action.
  5. Navigate to Admin Center -> Intelligent Service Center to notice that no event has been logged for "Employee Termination".

Cause

The correct event reason was not used to terminate the employee. Please note that the event reason used in the above-mentioned rule is Termination Non-Performance (TERINONP).

SAP_EVENT_TERM.png

If any other event reason was used to terminate the employee, the termination event will not be logged in ISC.

Resolution

You can add other Termination event reasons to the business rule's If statement. In the below example, we have added the event reason Inv Termination - Dishonesty (TERIDISH).

SAP_EVENT_TERM New.png

Now if an employee is terminated with either of the event reasons, the event will get logged in ISC under "Employment Termination" event.

Keywords

Rule, Register, Reason, Trigger, ISC , KBA , LOD-SF-EC-ITS , Intelligent Services (EC Components Only) , Problem

Product

SAP SuccessFactors HCM Core all versions