Symptom
You have maintained a Territory for a country XYZ (XYZ stands for a country), but you don't use postcodes for the Territory Rule. After finishing the Realignment Run, the territories are not entered in the Accounts for the country XYZ; the action Derive Territory in the Account does not bring the expected result either.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: you have created a Realignment Run with a Territory Rule for accounts with country XYZ and the run is finished.
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Go to the Customer workcenter.
- Go to the Accounts view.
- Open any Account with country XYZ. Note that the Territory field is not filled as per Territory Rule.
- Click Actions > Derive Territory.
Result: The Action Derive Territory does not bring a result either.
Cause
In the Territory Rule, you have manually entered the value * in the postcode field. At run time, the system matches the postcode values and the value * does not match with the postcodes maintained in the Accounts.
Resolution
If you do not want to maintain specific postcodes for the territory rule, please leave the field empty in the territory rule.
By default, the UI displays all cells of a rule which have not been provided as * as screenshot below:
This means that the rule is true irrespective of the value being stored in the corresponding field of the account.
If you manually entered a * the above list view would be exactly the same and you cannot distinguish between “*” (which is wrong) and the initial value which is always displayed as star.
To get the initial value use the “Clear” button.
Keywords
Territory ; Realignment Run ; Country; Post Code; Zip Code ; , KBA , account , territories , realignment run , post code , LOD-CRM-TM , Territory Management , How To
Product
Attachments
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