SAP Knowledge Base Article - Public

2574544 - Inbound E-Mail Error 'Unknown Recipient cod.b2b.servicerequest@my***.mail.crm.ondemand.com'

Symptom

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

When a customer replies to a ticket you receive a mail from Postmaster with the error 'Unknown Recipient cod.b2b.servicerequest@my***.mail.crm.ondemand.com'.

Please note that this same issue can occur for a B2C and Employee Support scenario.

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

Prerequiste:

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Open any open, relevant ticket.
  4. Send a reply to the customer.
  5. The customer on their side receive this mail and in their turn respond via e-mail.
  6. You receive a message from Postmaster@my***.mail.crm.ondemand.com with the message that 'Your message with subject *** could not be delivered. Details cod.b2b.servicerequest@my***.mail.crm.ondemand.com: <Unknown recipient cod.b2b.servicerequest@my***.mail.crm.ondemand.com >'

aaaaaaaaa.jpg

Cause

A possible cause could be that the scoping process did not get fully taken over into the backend.

Resolution

You need to un- and then re-scope the question: Do you want to support e-mail channels for corporate accounts?

  1. Go to the Business Configuration workcenter.
  2. Open the relevant Implementation Project.
  3. Edit Project Scope.
  4. Navigate to step 4 Questions.
  5. Select Service > Customer Care > Service Request Management.
  6. Under E-Mail Integration with Service Request Management for Corporate Accounts:
  7. Unscope the question: Do you want to support e-mail channels for corporate accounts?
  8. Save.
  9. Now set the check again to re-scope the question: Do you want to support e-mail channels for corporate accounts?
  10. Save.
  11. Once finished, the question should be back in scope.

aaa_scope.jpg

 

Should you still face issues, please open an case with SAP Cloud Product Support.

Keywords

Inbound E-mail, Unknown Recipient, email, Ticket, cod.b2b.servicerequest , KBA , LOD-CRM-SC-EML , Email , AP-RC-OUT , Output Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions