Symptom
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
When a customer replies to a ticket you receive a mail from Postmaster with the error 'Unknown Recipient cod.b2b.servicerequest@my***.mail.crm.ondemand.com'.
Please note that this same issue can occur for a B2C and Employee Support scenario.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
Prerequiste:
- You have scoped the question Do you want to support e-mail channels for corporate accounts? in your Business Configuration.
- You may (this is not mandatory) have set up an auto-forwarding within for example Microsoft Outlook to the address cod.b2b.servicerequest@my***.mail.crm.ondemand.com.
- You do not have the address cod.b2b.servicerequest@my***.mail.crm.ondemand.com maintained as e-mail channel as you are not using this as channel.
- Go to the Service work center.
- Go to the Tickets view.
- Open any open, relevant ticket.
- Send a reply to the customer.
- The customer on their side receive this mail and in their turn respond via e-mail.
- You receive a message from Postmaster@my***.mail.crm.ondemand.com with the message that 'Your message with subject *** could not be delivered. Details cod.b2b.servicerequest@my***.mail.crm.ondemand.com: <Unknown recipient cod.b2b.servicerequest@my***.mail.crm.ondemand.com >'
Cause
A possible cause could be that the scoping process did not get fully taken over into the backend.
Resolution
You need to un- and then re-scope the question: Do you want to support e-mail channels for corporate accounts?
-
Go to the Business Configuration workcenter.
- Open the relevant Implementation Project.
- Edit Project Scope.
- Navigate to step 4 Questions.
- Select Service > Customer Care > Service Request Management.
- Under E-Mail Integration with Service Request Management for Corporate Accounts:
- Unscope the question: Do you want to support e-mail channels for corporate accounts?
- Save.
- Now set the check again to re-scope the question: Do you want to support e-mail channels for corporate accounts?
- Save.
- Once finished, the question should be back in scope.
Should you still face issues, please open an case with SAP Cloud Product Support.
Keywords
Inbound E-mail, Unknown Recipient, email, Ticket, cod.b2b.servicerequest , KBA , LOD-CRM-SC-EML , Email , AP-RC-OUT , Output Management , Problem