Symptom
When you try to adjust the Quantity of hours for an item, the change does not stick and the system reinserts the previous value.
Environment
SAP CLOUD FOR CUSTOMER 1711 / 03
Reproducing the Issue
-
Go to the Services work center.
- Go to the Tickets view.
- Open ticket XXX (XXX represents the ID of ticket).
- Go to the Service and Repair tab.
- Under Items section, try to update a field quantity which type is equal to hour.
- Press enter.
- The value returns to the original one.
Cause
As the quantity of time is determined by the interval between the start and end time, it is not possible to adjust the amount directly.
Thus, the start and end time must be changed accordingly in order to obtain the desired amount of hours.
Resolution
This is the system expected behavior.
If you want to adjust the quantity of hours of an item, you should change the Actual Start time or the Actual End time by doing the following:
-
Go to the Services work center.
- Go to the Tickets view.
- Open ticket XXX.
- Go to the Service and Repair tab.
- Click on Edit button.
- Under Items section, select the item for which you want to adjust the quantity of hours.
- Under General Data tab, adjust Actual Start field and the Actual End field if needed.
- Save it.
- The hours quantity will be adjusted on Items section.
Keywords
Item; Quantity; Hour; Type; Update; Change; Ticket; , KBA , LOD-CRM-SRP-UI , Ticket Related UI , How To