SAP Knowledge Base Article - Public

2574811 - Failed to send data to SF: Token is expired. in Audit Trail for Event Code - Onboarding 1.0

Symptom

  • In Audit Trail of affected candidate, SF_INTEGRATION event shows paperworkdone SourceID as Failed to send data to SF: Token is expired.
  • In Manage Data > OnboardingCandidateInfo, ReadyToHire and Hired is equals to No after completeting New Employee Step
  • In Manage Pending Hire, affected candidate is not visible

Environment

SAP SuccessFactors Onboarding 1.0

Reproducing the Issue

Audit Trail

  1. Navigate to SAP SuccessFactors HCM > Onboarding > Settings > Manage Employees
  2. Search affected candidate and highlight to show Audit Trail button
  3. Click Audit Trail button and adjust the date range
  4. Event Code (SF_INTEGRATION) and SourceID (paperworkdone)
  5. Source description shows as Failed to send data to SF: Token is expired. 

Manage Data

  1. Navigate to SAP SuccessFactors HCM > Admin Center > Manage Data > OnboardingCandidateInfo
  2. Find the candidate by searching the name or applicant ID
  3. ReadyToHire and Hired is equals to No after completeting New Employee Step 

Manage Pending Hire

  1. Navigate to SAP SuccessFactors HCM > Admin Center > Manage Pending Hire
  2. Click dropdown and select Onboarding
  3. Affected candidate is not visible

Cause

SAP SuccessFactors HCM is down or unavailable at the time the event was sent or canidate completed NES.

Resolution

For Live Customer(s)

Please reach out to SAP SuccessFactors Cloud Product Support in SAP for Me via SAP Expert Chat or Support case. In addition, follow the template when creating an case and provide the needed information below.

  • Subject: KBA 2574811 - Failed to send data to SF: Token is expired.
  • Component: LOD-SF-OBD-INT

Problem Description:

  1. BizX Company ID 
    • [Insert affected instance]
  1. Affected Hire/Candidate
    • [Insert affected hire/candidate's name]
    • [Insert screenshot of the issue]
  1. Permission to run a script to identify affected users and re-send the event
    • [Insert approval]
  1. Username for Support Access (Read the agreement below)
    • [Insert Username]

May we have your approval for accessing your system environment to continue request? (Reply with your confirmation and username to access, refer to KBA listed below)

With your approval, accessing your system environment you agree for the actions we will take below.

    1. Review the data of affected users and compare it to those users who are working as expected.
    2. Capture screenshots/record screen clips of the issue.
    3. Analyze your system configuration

To know  how to grant support access to SAP Cloud Product Support, please read the full article on 'How to Grant Support Access to SuccessFactors Support Staff' by clicking the reference KBA 2088892.

For Implementation Partner(s) and Consultant(s)

SAP SuccessFactors Cloud Product Support do not trigger this kind of request with preview environments, but you may do the following to re-send the paperworkdone event to BizX:

  • Restart activity back to NES and complete
  • Follow the customer process mentioned above 

For SAP SuccessFactors Cloud Product Support

Please use the instruction manual on how to proceed, in the internal note

See Also

Keywords

OBD, ONB, INT,  BizX, Integration, Failed to send data to SF, Token, is, expired, paperworkdone, error, Onboardingcandidateinfo, updatedata , KBA , LOD-SF-OBD , Onboarding , LOD-SF-OBD-INT , Integrations with Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions