SAP Knowledge Base Article - Public

2575187 - Check Connection Test for an Outgoing ERP/CRM Communicaiton Scenario fails

Symptom

You test the connection of your outgoing ERP/CRM communication scenario. The checking connection and ping fails. In many cases an internal error 500 appears.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the Facet General Settings.
  3. Click on Communication Arrangement.
  4. Open any outgoing ERP/CRM Communication Scenario, e.g. Business Partner Replication to SAP ERP.
  5. Click on View All.
  6. Go to Facet Technical Data.
  7. Click on Edit Advanced Settings.
  8. Select the service and click on Check Connection.

The checking connection and ping fails. In many cases an internal error 500 appears.

Cause

The Check Connection function from the Communication Arrangement, is a ping test that will always give broken connection error even if the scenario is working properly. Because your system is an ABAP system pinging a Non ABAP system (, i.e. HCI) it is not possible to generate an accurate response can be anything. Please use the alternative test connection from the Communication Arrangement for On-Premise Integration.

Resolution

  1. Go to the Administrator workcenter.
  2. Go to Facet Common Tasks.
  3. Click on Communication Arrangement for On-Premise Integration.
  4. Click on Test Connection button.
  5. Select the ERP/CRM System.
  6. Maintain the mandatory fields and choose a middleware (if available).
  7. Click on Test Connection button.

The System will switch to Facet Connection Results displaying the results of your connection test.

Keywords

Checking connection failed
Error accessing service; Service Ping ERROR: Error when calling SOAP Runtime , KBA , service ping error , checking connection failed , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions