SAP Knowledge Base Article - Public

2575840 - How to Remove Lock from Components in Cloud Applications Studio

Symptom

 You tried to open/edit a PDI component (script file, BO, xBO) and receives the error message 'Solution is locked by the following user XXX (XXX stands for the UserID)'.

Environment

  • SAP Cloud Applications Studio
  • SAP Cloud for Customer
  • SAP Business ByDesign

Reproducing the Issue

  1. Log on to SAP Cloud Applications Studio.
  2. Connect to the Repository.
  3. Enter your System Details.
  4. Enter your User ID and Password.
  5. Click on OK.
  6. Double click on your Solution.
  7. Check in Solution Explorer.
  8. Choose your respective Business Object/Script File/Extension BO.
  9. Try to add an element, modify or activate and while saving it system throws an error message.
  10. Solution is locked by the following user XXX.

Cause

The user XXX has failed to Check In all the component in his custom solution or due to system upgrade the files has automatically locked.

Resolution

Please be aware that forcibly removing the lock will prevent the user's current changes from being saved.

To remove the lock, follow these steps below:

  1. Within the solution, click on Administration from the menu bar.
  2. Select Session Administration.
  3. Highlight the respective lock and delete it.

If you are unable to view or release the lock in the Session Administrator, please submit a case to SAP Support and grant us permission to remove the lock from the backend.

Keywords

Lock, PDI, Component, SDK, Remove, Locked, Session, Session Administration, XREP, Solution , KBA , session administration , AP-RC-BDS-1O , ByDesign Studio OneOffs , BC-DWB-REP-XRP , Lean Stack xRepository , How To

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions