Symptom
The Party Determination for a Ticket does not work for Tickets created via E-Mail or from an unassociated E-Mail, when only the Step Current User is selected in the Determination.
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
-
Go to the Business Configuration work center.
-
Select the Implementation Projects view.
-
Select the Open Activity List hyperlink.
-
Switch to the Fine-Tune facet.
-
Search for the Tickets for Customer Support activity and open it.
-
Select the Maintain Involved Parties hyperlink.
-
Select Party Role ABC (ABC represents the Party Role ID).
-
Select the Maintain Determinations hyperlink.
-
Only select the Step 40: Current User.
-
Select the OK button.
-
Select the Save and Close button.
The Party Role ABC is not determined automatically, when creating a Ticket from an unassoiciated E-Mail or when a Ticket is created through an incoming E-Mail.
The Determination only works, when a Ticket is created manually.
Cause
This is the expected system behaviour in SAP Hybris Cloud for Customer.
Resolution
When a Ticket is created via incoming E-Mail, there is no current User available at the moment of the creation.
An unassociated E-Mail is one that couldn't be converted to a direct ticket via integration due to certain business reasons.
When a user opens an unassociated email and converts it to a Ticket, the logic of the ticket is to respect the origin / source of the data and in this case, since it's an email scenario, the copy logic obtains the information it requires based on the data that is persisted in the E-Mail activity Business Object instance.
Keywords
E-Mail Ticket Party Determination Current User Unassociated Manual Incoming , KBA , LOD-CRM-SRP , Service Request Processing , Problem