Symptom
You have checked the box "For hard-bounced e-mails due to invalid address, assign task to account owner", but no Activity Task is assigned to the Account Owner when an email bounces.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to the Sales Campaign work center.
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Go to the Campaigns view.
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Open Campaign XYZ (XYZ represents the ID of the campaign).
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On the Overview tab, see that the "For hard-bounced e-mails due to invalid address, assign task to account owner" box is checked.
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Go to the Execution Details view and see that there is one or more bounces.
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On the bounce line, open the Account 123 (123 represents the ID of the Account).
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Go to the Activities tab
Result: No task related to the campaign is present.
Cause
The action "For hard-bounced e-mails due to invalid address, assign task to account owner" creates a BTM Task for the employee who owns the account to check the reason for the bounce. It does not create an activity task. This is shown to the user on the notifications.
Also, these tasks are only going to be created for the case of a hard bounce for an e-mail address invalid scenario.
Resolution
This is the expected system behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
Keywords
Campaign; Bounce; Task; Account; Notification; BTM , KBA , LOD-CRM-MKT-CAM , Campaigns , How To