Symptom
'Search' option is not available for an LMS admin
Environment
SAP Successfactors Learning Management System (LMS)
Reproducing the Issue
- Log in to LMS.
- Switch to the 'Admin' tab.
- Select the entity with issue (Users > Users, Users > Assignment Profiles, Users > Event Rules, etc.).
- 'Search' option is not available.
Cause
The 'Search' workflow for that entity is not in the role assigned to the admin.
Resolution
Add the missing search workflow.
- Log in to LMS as Admin.
- Navigate through System Admin > Security > Role Management.
- Search for one of your assigned roles that should have this search capability.
- Click 'Edit' (pencil icon).
- Switch to 'Workflows' tab.
- Click 'add one or more from list'.
- Expand 'Search'.
- Select the checkbox of the corresponding entity in concern (e.g. 'Search Certificate Template' if search option is not available in Admin > Configuration > Certificate Templates).
- Click 'Add' button. If a warning message appears, just click 'OK'. (It says "This action may take more than a few seconds. Please wait for the page to be refreshed.")
- Click the 'Apply Changes' button.
- Expand 'Search' and double-check if the selected workflow is added.
- Now, log in with an Admin ID having this role and it should have the missing search option.
See Also
2285302 - LMS - Which workflow allow administrators to search for quizzes in the LMS?
2506384 - Admins cant search for online items in collection admin side - LMS
Keywords
search, search option, search button, button, LMS, learning, record , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS , Learning Management System , Problem
Product
SAP SuccessFactors Learning all versions