Symptom
You have created an activity and noticed that the 'Sales Territory' was not assigned. We'll consider that the activity created for this example is a task.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Activities work center.
- Go to the Tasks view.
- Open the task 123 (123 represents the task ID).
- The Sales Territory field is blank.
Cause
The question "Do you want to determine the transaction’s territory based on the document owner as well as the account?" is not in the system's scope and the activity was created without an account assigned.
Resolution
You need to scope the question "Do you want to determine the transaction’s territory based on the document owner as well as the account?" following the steps below:
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Select the current Project.
- Press 'Edit Project Scope'.
- Go to the step 'Questions'.
- Expand Sales -> Account and Activity Management -> Territory Management.
- Check the box for the question "Do you want to determine the transaction’s territory based on the document owner as well as the account?".
You can enable this Business option if you would like to default the territory based on the owner of a transaction. The determination occurs as below:
- In cases where multiple territories are assigned to an account and owner, the transaction will default the matching territory.
- If multiple territories match, the system will provide a warning message.
- If only one territory exists for the account and not for the owner, the system defaults to the account territory.
- If only one territory exists for the owner and not for the account, the system defaults to the owner’s territory.
- Documents that do not have an account assigned, will also be defaulted to the territory that is assigned to the owner of the document if the owner is assigned only with this territory.
Keywords
Task, Activity, Territory, Sales , KBA , LOD-CRM-ACT , Activities , LOD-CRM-TM , Territory Management , How To