SAP Knowledge Base Article - Public

2577794 - How The Completion Date Is Determined Automatically In Tickets

Symptom

You have created a ticket without Service Level maintained. The SLA for Completion Date field is calculated while you expected to have it blank.

Environment

SAP Cloud for Customer Core Applications

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets view.
  3. Create a new ticket without the Service Category.
  4. Fill the mandatory fields and click the Save & Open button.
  5. The Completion Date is filled automatically, even though the SLA is based on Service Category.

Cause

The Completion Date is filled when a Service Level with corresponding reaction times is assigned in the Service Level to the ticket. The Completion Due Date will be calculated on these reaction times.

When the ticket does not have a Service Level assigned, the fallback reaction times from the Date Profiles are taken (initial review / completion). They are used for the calculation of the due dates.

Additionally, any bank holidays defined in the holiday calendar are considered.

Resolution

To set the Completion Due Date you can follow the steps below to set the Date Profiles in Business Configuration:

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Select active project.
  4. Click Open Activity List.
  5. Select and open Date Profiles.
  6. Under Date Variable Service set the Completion Time (in hours).

KBA.PNG

To check the bank holiday calendar:

  1. Go to the work center Business Configuration > Overview.
  2. Search for the activity Working Day Calendar and open it. 
  3. Click Maintain an existing holiday calendar.
  4. Expand the country relevant for the tickets in question and open the holiday calendar. You will see a list of available holidays, and a list of selected holidays.

Keywords

Tickets, SLA, Service Level, Completion Date, completion due, wrong date, wrong timeline, determined incorrectly , KBA , LOD-LE-CSM-SVL , Service Level Objective , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions