Symptom
You have assigned a new Business Role or made some modification in the Access Rights for an user, however after making the changes, the same are not updated for the user.
Environment
- SAP Cloud for Customer
- SAP Business ByDesign
Cause
It is mandatory to perform Update Access Rights after you make any changes in the access rights or business roles for an user to synchronize the changes. If you don't perform the same then the User's right are not updated with the changes.
Resolution
In SAP Business ByDesign:
- Go to Application and User Management Work Center.
- Select Business User view.
- Select the User.
- Select the button Update User Access.
- Select Update All Users.
In SAP Cloud for Customer:
- Go to Administrator Work Center.
- Select Business User view.
- Select the User.
- Select the button Update User Access.
- Select Update All Users.
This will synchronize the updates/modification made in the Access Rights for the user.
When the issue is related to Business Role, sometime, only Update Access Rights may not synchronize the access rights. In such case, there are two methods can be taken.
- Remove the new assigned Business Role from the business user.
- Save.
- Update Access Rights.
- Re-assign the Business Role.
- Save.
- Update Access Rights.
Or
- Make any change in the issued Business Role.
- Save.
- Update the user.
- Recover the Change.
- Save.
- Update the user.
Keywords
Access Rights, Business Role, Access not updated, byd, c4c , KBA , access rights , access not updated , SRD-CC-IAM , Identity & Access Management , How To