Symptom
You sent a sales quote to a customer through the C4C system. A few seconds later, a bounce email is sent to your email server address with the following error: 'Delivery Failed'. However, the status of the sales quote appears as successful in C4C.
Environment
SAP Hybris Cloud for Customer 1711
Reproducing the Issue
- Go to the Sales work centre.
- Go to the Sales Quote view.
- Search and open sales quote ABC (ABC represents the ID of the sales quote).
- Open the Output facet.
- Select the row where you can see the .pdf file under File Type.
- Click on the Resubmit button.
- Type an e-mail address where you want to send the sales quote.
- Click on the Resubmit button.
An e-mail is sent from the sales quote owner's address to the e-mail address.
A bounce e-mail is sent to the technical address with the following message: 'DELIVERY FAILURE: 550 Requested action not taken: mailbox unavailable'. - Click on E-Mail Text tab.
Result: The bounce e-mail is not there. - Click on Output Details tab.
Result: The status is successful.
Cause
Your system sent the sales quote from the owner's e-mail address. However, the bounce e-mail was sent to your e-mail server address and the e-mail was not forwarded to the system.
Example:
Sales Quote E-mail:
- Sender: owner.sales.quote@thecompanyname.com (e-mail from the owner of the sales quote)
- Recipient: abcdefg123@xxx.com (e-mail address where you try to send the sales quote).
If the recipient is not reacheable, a bounce e-mail will be sent to your e-mail server:
- Sender: abcdefg123@xxx.com
- Recipient: Postmaster@yourcompany.com (e-mail server address)
Resolution
There is error handling in place to catch issues with e-mail transmission and raise a relevant error. This error occurs when the bounce e-mail comes from a dedicated C4C system e-mail address, for example technical.address@myxxxxx.mail.crm.ondemand.com. If the message is sent from a technical address, the non-reachable e-mail address is identified and the error is processed.
Your e-mail configuration should also be set up to route bounce mails back to the system.
Keywords
sales quote, successful, e-mail, DELIVERY FAILURE, 550 Requested action not taken: mailbox unavailable , KBA , AP-RC-OUT , Output Management , How To