SAP Knowledge Base Article - Public

2578221 - A Sales Quote Appears with Status Successful When the E-mail Delivery Failed

Symptom

You sent a sales quote to a customer through the C4C system. A few seconds later, a bounce email is sent to your email server address with the following error: 'Delivery Failed'. However, the status of the sales quote appears as successful in C4C.

Environment

SAP Hybris Cloud for Customer 1711

Reproducing the Issue

  1. Go to the Sales work centre.
  2. Go to the Sales Quote view.
  3. Search and open sales quote ABC (ABC represents the ID of the sales quote).
  4. Open the Output facet.
  5. Select the row where you can see the .pdf file under File Type.
  6. Click on the Resubmit button.
  7. Type an e-mail address where you want to send the sales quote.
  8. Click on the Resubmit button.
    An e-mail is sent from the sales quote owner's address to the e-mail address. 
    A bounce e-mail is sent to the technical address with the following message: 'DELIVERY FAILURE: 550 Requested action not taken: mailbox unavailable'.
  9. Click on E-Mail Text tab.
    Result: The bounce e-mail is not there.
  10. Click on Output Details tab.
    Result: The status is successful.

SalesQuote_email_successful.png

Cause

Your system sent the sales quote from the owner's e-mail address. However, the bounce e-mail was sent to your e-mail server address and the e-mail was not forwarded to the system.

Example:

Sales Quote E-mail:

If the recipient is not reacheable, a bounce e-mail will be sent to your e-mail server:

Resolution

There is error handling in place to catch issues with e-mail transmission and raise a relevant error. This error occurs when the bounce e-mail comes from a dedicated C4C system e-mail address, for example technical.address@myxxxxx.mail.crm.ondemand.com. If the message is sent from a technical address, the non-reachable e-mail address is identified and the error is processed.

Your e-mail configuration should also be set up to route bounce mails back to the system.

Keywords

sales quote, successful, e-mail, DELIVERY FAILURE, 550 Requested action not taken: mailbox unavailable , KBA , AP-RC-OUT , Output Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions