SAP Knowledge Base Article - Public

2578597 - Eligibility Page is Stuck After Applying Rules in Compensation

Symptom

  • Plan Setup > Plan Details> Eligibility page is stuck after Applying eligibility rules
  • How can we update the page, so we are able view/edit rules again?

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Compensation

Reproducing the Issue

  1. Login and navigate to Compensation Home > Plan Setup > Plan Details > Eligibility
  2. The eligibility page will appear as seen in the below screen shot:

compensation eligibility rules screen.png

Cause

  • The Apply Eligibility Job has failed/terminated or is currently still in-progress however the status is not marked correctly
  • In some cases the rules are already applied, so the flag in the database is already updated with the rule running and goes out of sync. The database flag must be cleared manually, allowing changes to be made in the UI

Resolution

  • To update this page so you're able to view/edit rules please reach out to your Implementation Partner.
  • From Provisioning, clear the eligibility rule flag against the template in question
  1. Provisioning > Manage Compensation > Clear Eligibility Rule Flag:

clear eligibility rule flag.png

  1. Select the Appropriate Template:

clear flag template.png

  1. Clear

Keywords

sf, success factors, CMP, clear eligibility rule flag, eligibility page stuck, unable to edit rules, compensation eligibility page , KBA , LOD-SF-CMP , Compensation Management , LOD-SF-CMP-EC , EC data, EC mappings, configuration & settings , Problem

Product

SAP SuccessFactors Compensation all versions ; SAP SuccessFactors HCM suite all versions