SAP Knowledge Base Article - Public

2578719 - Extension Field added in Tickets Screen using UI Designer not Visible in Fiori (RUI)

Symptom

You have added extension field in Tickets TI screen and made it visible in your solution, using UI designer. But this field is available in HTML5 but not in Fiori (RUI)

Environment

[Enter your Environment here...]

Reproducing the Issue

  1. In SDK, launch Tickets TI screen.
  2. UIComponent: /BYD_COD/ServiceOnDemand/AgentWorkspace/COD_SEOD_Agent_Workspace_TI.TI.uicomponent
  3. Add extension fields using UI designer.
  4. When checked in browser, fields are not visible in Fiori (RUI)

Cause

The ticket object uses different floorplan for Fiori and HTML5 UI. Fiori UI is based on tablet floorplan.

Resolution

You need to re-add extension fields in actual floorplan to reflect changes in Fiori (RUI).

  1. In SDK, launch Tickets TI screen.
  2. UIComponent: /BYD_COD/ServiceOnDemand/Collaboration/COD_SR_TI.TI.uicomponent.
  3. Add extension fields using UI designer.

See Also

[Enter your See Also here...]

Keywords

[Enter your Keywords here...] , KBA , ticket ti , ui designer , ticket floorplan , extension fields in fiori , extension field in ui , AP-RC-MOB-UIF , Responsive UI , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions