SAP Knowledge Base Article - Public

2579280 - Registered Product Serial ID Cannot be Started with "0"

Symptom

When you create a new Registered Product, enter a serial ID with prefixed 0, then you will find the prefixed 0 removed by system automatically.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to Product work center.
  2. Go to Registered Product work center view.
  3. Create a new Registered Product by clicking “New” button.
  4. Enter the serial ID such as “000123”.
  5. Click “Save and Open”.
  6. Find the serial ID become "123" in the new Registered Product, all the "0" in the beginning of serial ID are deleted. 

Cause

This is standard behavior of underlying data type.

If you enter a numeric value prefixed with 0 in a field which is of alphanumeric data type then the prefixed 0 will be removed.

The prefixed 0 will only be retained if the entered value has some alphabet or allowed special character.

Resolution

Please DO NOT maintain the serial ID with prefixed 0.

As a workaround, you can enter the serial ID such as “S-000123”.

PS: Registered Product Serial ID field value is alphanumeric and supports alphabet A - Z, numbers 0 - 9, hyphen (-), underscore ( _ ), colon (:), any other characters other than the above mentioned are not supported.

Keywords

Registered Product; Serial ID; prefixed 0; , KBA , LOD-LE-IBA-IPO , Installation Point , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions