SAP Knowledge Base Article - Public

2580205 - Default Value of a KUT Field is Not Working as Expected

Symptom

You have configured a default value for a KUT field inside of it's properties. However, after applying this, the field is not showing the default value.

Environment

  • SAP Cloud for Customer
  • SAP Business ByDesign

Reproducing the Issue

  1. Go to any Work Center view for e.g. Accounts.
  2. Open any Account.
  3. Start Adaptation.
  4. Create a new field with a default value filled (or edit a current KUT field and set a default value).
  5. Open any Account and click Edit.
  6. The default value for the field is not filled.

Cause

  • Defaulting works only for the new instance.
  • Create e.g. a new Account and click Edit.
  • The default value will be filled for the field "A".
  • It will not default for the existing documents.

Resolution

The default value set for this field will work just for new created records. It will not override already created records with this new set default value.

For example, after setting the default value it will appear only for new created Accounts (or other objects). The already created Accounts will remain with the old value.

Keywords

Defaulting in Extension field, default value, extension field, KUT, field, account , KBA , extension field , default value , defaulting in extension field , AP-RC-UIF-FLX , Page Layout & Key User Configuration , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions