SAP Knowledge Base Article - Public

2580367 - 'Is Deleted' Filter returns no data - Integration Center

Symptom

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

In this document we will go through the process of filtering an Integration Center Job using the 'Is Deleted' filter. Sometimes, this filter can cause issues and may return no data (even when there is data present) when filtering a report.

Environment

  • SuccessFactors
  • Integration Center

Reproducing the Issue

1. Query a starting entity - take JobRequisition as an example.

2. Attach the 'Is Deleted' field to the Integration Center Job.

   2.1. Attempt to use Filter Functionality - filtering by 'Deleted':

   filterOptions.PNG

3. No data returned in output:

   noData.PNG

Cause

Filter values for the 'Is Deleted' standard enitity are:

Resolution

1. Enter the values 0 or 1 in the Filter Functionality option in Integration Center - avoid 'Deleted or 'Not Deleted'.

See Also

Integration Center - Standard Documentation

Keywords

Integration Center, Is Deleted, Filter, Filter Options, Integration Center job , KBA , LOD-SF-INT-INC , Integration Center , LOD-SF-RCM-INT , Integration Center & Intelligent Services , How To

Product

SAP SuccessFactors HCM Core 1711