Symptom
While creating a Registered Product using the web service, error message occurs.
Environment
Web Services : RegisteredProductReplicationInitiatedByExternalIn
Reproducing the Issue
-
You are creating a Registered Product using the Service Interface : "RegisteredProductReplicationInitiatedByExternalIn".
- You are getting the error : "Contact xxxxxx is not active" in Web Service Message Monitoring.
Cause
- There is a contact determination which happens automatically when a customer is entered for a registered product.
- Here the general assumption is that the customer has a main contact which is in status "active".
- Since it was not active in this case hence the error.
Resolution
This is the current system behaviour.
Keywords
Contact is not active, Registered Product, RegisteredProductReplicationInitiatedByExternalIn , KBA , LOD-LE-IBA-IPO , Installation Point , Problem
Product
SAP Cloud for Customer add-ins 1802 ; SAP Hybris Cloud for Customer add-ins 1711