Symptom
- Interface is failing with an expired password
- You reset the password in SFSF instance
- You want to change the password in Boomi environment extension
- You change only the password and re-run the interface
Environment
- SAP SuccessFactors HCM Suite
- Boomi
Cause
The issue is specific to encrypted fields (password when saved into DB goes as an encrypted field)
Resolution
Along with the password field, please change a field like “username” to reflect the changes in the environment extension.
Procedure
- Check the correctness of the username/password by logging into the UI after the password reset and keep it ready.
- In respective connector, change the username and password to a different API user --> Save the extensions
- Now, revert this to the username which was maintained along with the password which was reset --> Save the extensions
- This will save the password correctly
Idea submitted to Boomi to rectify the issue: https://community.boomi.com/ideas/3617
Enhancement: BOOMI-18919
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This has been followed up with Boomi Support & they have confirmed that this has been fixed in the below item & was delivered in May 2018:
- (Platform-18919) Extension values that are encrypted, such as passwords are not updated properly. THe initial value continues to be applied
When updating API credentials in standard or custom Boomi processes please ensure valid credentials are being used (i.e. they have been validated independently of Boomi) & the correct Environment Extension is being updated
Keywords
unauthorised user,401,401 in boomi successfactors,boomi,boomi extensions not saved when only pas,failed authentication , KBA , LOD-SF-INT-BPI , Dell & Boomi Infrastructure , LOD-SF-INT , Integrations , Problem
SAP Knowledge Base Article - Public