SAP Knowledge Base Article - Public

2580467 - [BUG-FILED] Boomi extensions not saved when only password field is updated

Symptom

  1. Interface is failing with an expired password
  2. You reset the password in SFSF instance
  3. You want to change the password in Boomi environment extension
  4. You change only the password and re-run the interface

Environment

Boomi

Cause

The issue is specific to encrypted fields (password when saved into DB goes as an encrypted field)

Resolution

Along with the password field, please change a field like “username” to reflect the changes in the environment extension.

Procedure

  1. Check the correctness of the username/password by logging into the UI after the password reset and keep it ready.
  2. In respective connector, change the username and password to a different API user --> Save the extensions
  3. Now, revert this to the username which was maintained along with the password which was reset --> Save the extensions
  4. This will save the password correctly

Idea submitted to Boomi to rectify the issue: https://community.boomi.com/ideas/3617

Enhancement: BOOMI-18919

Keywords

  • unauthorised user
  • password expired
  • failed authentication
, KBA , password expired , unauthorised user , 401 , 401 in boomi successfactors , boomi , boomi extensions not saved when only pas , failed authentication , LOD-SF-INT-BPI , Dell & Boomi Infrastructure , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors HCM Core all versions