Symptom
- Interface is failing with an expired password
- You reset the password in SFSF instance
- You want to change the password in Boomi environment extension
- You change only the password and re-run the interface
Environment
Boomi
Cause
The issue is specific to encrypted fields (password when saved into DB goes as an encrypted field)
Resolution
Along with the password field, please change a field like “username” to reflect the changes in the environment extension.
Procedure
- Check the correctness of the username/password by logging into the UI after the password reset and keep it ready.
- In respective connector, change the username and password to a different API user --> Save the extensions
- Now, revert this to the username which was maintained along with the password which was reset --> Save the extensions
- This will save the password correctly
Idea submitted to Boomi to rectify the issue: https://community.boomi.com/ideas/3617
Enhancement: BOOMI-18919
Keywords
-
unauthorised user
- password expired
- failed authentication
Product
SAP SuccessFactors HCM Core all versions