Symptom
-
Field is not available as filter in Manage Filters for a Recruiting V2 report in ORD
-
The same field is available to be filtered in Runtime Filters or in Adhoc report
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to ORD and open a Recruiting V2 report
- See that a specific field, such as "Gender", is selected in the query
- Go to Edit > Runtime Filters > and the "Gender" field will be available
- Now go to Manage Filters and check that this field is missing
Cause
- The field is configured with different picklist-ids in all the Job Requisition or Application templates.
- For example, the gender field is set as <picklist-id>RCM_gender</picklist-id> in the Application template A; however, in the Application template B, the gender field is set as <picklist-id>APP_gender</picklist-id>.
Resolution
- Modify the templates to use the same picklist-id.
- Making this modification will affect all the Job Requisitions or Applications that used these templates.
- If template modifiction isn't desired, use the field in runtime filters.
- The calculated column is not a workaround because it does not support conditional statement, function or picklist to be used as filter.
Keywords
sf, success factors, ORD , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , LOD-SF-RCM , Recruiting Management , Problem
Product
SAP SuccessFactors HCM Suite all versions