SAP Knowledge Base Article - Public

2580694 - You are not Able to Edit a Product or to add an Attachment via Products View

Symptom

You are not able edit a product via Products view in the Products work center. For example, it is not possible to add an attachment. The Add button is grayed out and there is no Edit button.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Products work center
  2. Select the Products view
  3. Select any available Product
  4. Go e.g. to the Attachments tab
  5. The Add button is grayed and no Edit button is available

Cause

This is expected system behavior. The editing of products is done in the Product Administration view.

Resolution

To add an attachment to a product or to edit it, open the product in the Product Administration view.

  1. Go to the Products work center
  2. Select the Products Administration view
  3. Select any available Product
  4. Go e.g. to the Attachments tab
  5. Click on Edit (pencil) button or Add button

Keywords

Products, Add, Edit, Attachments, missing, change, changing , KBA , LOD-CRM-PM , C4C Product Management , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions