SAP Knowledge Base Article - Public

2580893 - Data Workbench Job Stuck for Account Hierarchy

Symptom

You are trying to add or update account hierarchies using Data Workbench, however, the job is stuck in process. Zero or only a few records are processed. After this, the job remains in process with no progress.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Enter Data Workbench work center.
  2. Navigate to the Import tab.
  3. Select Individual Objects mode and search for object Account Hierarchies.
  4. Upload the file and proceed until the import starts.
  5. Go to the Monitor tab of the work center.
  6. From there, you can see that the job is stuck with status "In Process".

Cause

This issue happens because at least one account used in the hierarchies is set as "Blocked". During the import process of account hierarchies, the data workbench tries to lock the account temporarily to execute the needed changes. The case is that when the account is blocked, the Data Workbench is not able to execute this lock, so the job is not processed properly.

Resolution

Make sure that all the accounts being used in the import job are not blocked in the system. Regarding the stuck job, generally the Data Workbench jobs that remains in process for more than 6 hours are automatically terminated. If the job is not automatically finished after 6-7 hours, report an case.

Keywords

Hierarchies, DWB, Account, Import , KBA , LOD-CRM-INT-DWB , Data Workbench , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions